Beta Release: 4.5 - Dual USB Controller Support

  • Last Post 08 September 2017
rscott posted this 19 August 2017

A month or so back I decided to build a version that would use a 2nd USB stick in my computer to send commands to non-secured devices. The intent with this version was to build a more responsive z-wave experience, as often-times slow polling devices would cause annoying delays when trying to turn a device on or off. In our experiment in our demo home, it has been working pretty nicely.

If you have a 2nd USB stick laying around, I'd be interested in hearing how your own experience with this is. Please let me know if you had z-wave related slowdowns previously and if this has helped. To use this, add a port to your "2nd z-wave controller" box in the tools/options menu. Do note that you'll need to go offline/online again anytime you change this port.


Order By: Standard | Newest | Votes
jonnysax posted this 21 August 2017

Thank Scott!  I'll try it.  

weidnerj posted this 22 August 2017


Tried it and had to roll back.  Only have one controller (verses two controllers) and found that it wasn't allowing devices to be turned on via console.  I would click on icon to turn light on and it woudn't come on (or go off).  If the light was turned on by zwave remotes, it would show a status.  Had a scene where motion turned on outside lights and the lights wouldn't come on.  Even removed and readded without any luck.  Uninstalled and rolled back to the previous version and it worked.  Play with cutting edge software, going to bleed a little...

rscott posted this 22 August 2017

@weidnerj - Did you have your secondary port set to something other than 0 (tools/options/zwave)?


weidnerj posted this 22 August 2017


I just installed over the top of the previous version and didn't change any settings. Will reinstall tonight and see if I can reproduce what I saw yesterday

weidnerj posted this 23 August 2017


Just tried it again, and it was set for 0 as the 2nd controller, the other controller is set for com 3.  Can lock and unlock the door, but can't turn on the light switches or outlets.  Virtual devices seem to work (icon changes on click).   The kicker is that the devices report their status ok, so if I have a light on, it shows it being on, but can't change the status.

weidnerj posted this 04 September 2017

Any new builds?

rscott posted this 06 September 2017

I'll post a new build toward the end of the week.

rscott posted this 08 September 2017

Here's release 4.5.6460. This one should fix the problem with the secondary controller set with "0" as the COM port still trying to send commands. It also includes the feature I mention in this YouTube video: 

weidnerj posted this 08 September 2017


That version works much better.  Now I can using the console can turn on and off devices and my virtual devices also work.