Delays between some device triggers and scene execution

  • Last Post 3 weeks ago
MadSci posted this 3 weeks ago

Not sure what the deal is but some devices will trip but the scene which is triggered by the device takes 1-3 minutes to execute. This has been an issue over the last month or more and I've tried everything to fix it and avoid posting here, e.g. re-connecting devices, double checking assoications, auto-configure, deleting the scene and making a new one. It appears to happen with only certain types of devices. I have two different tilt sensors (two different brands) and two different branded motion sensors and they all cause the same issue. My door sensors and water sensor don't appear to have this issue. The log shows that the device was in fact tripped, other actions sometimes occur in the log and then eventually the scene triggers so I don't think Axial is hanging up on something. This may have conincided with a recent software update, not sure.  

Anyone have this issue before or currently? Any ideas on how maybe to investigate further?  

Order By: Standard | Newest | Votes
rscott posted this 3 weeks ago

Could you add a notification or email command to the end of the scene and see if that is also delayed? Do you have the delay when you activate the screen manually?

  • Liked by
  • MadSci
MadSci posted this 3 weeks ago

Hi Ryan -

I have emails set up. Both the log file and the email time stamp "<now>" indicates that the scene is not being executed immiedately upon the device being triggered. If I activate the scene manually, there is no delay with the email. Also, it does appear that the conditions are not being checked until after the delay.  It's with different devices and different scenes all of which have deleted and re-done several times. Oddly, like I said, it only appears to be with specific devices.  




rscott posted this 3 weeks ago

Can you explain how the scene is setup? Do you have any pre/post scripts? If you add an email as the very first item, and keep one at the very end, is the first one delayed or does it send immediately? 

MadSci posted this 3 weeks ago

No scripts. Just "send email command" device is the only thing present in the garage door notification scene. There is another scene which also uses the garage door opening to set a virtual device which also doesn't trigger in a timely fashion. The motion sensor scene to turn on a light in my office is also delayed and only has the device switch. I've tried dumbing down the scene as much as possible with no luck. 


Here is what the log looks like when the garage door is opened (node 13). You can see that there is 45 seconds delay this time (it appears to vary) between Axial recieving the report and the scen being triggered. 

3/6/2018 8:28:36 AM: Unprocessed parameter Zensor_Net_Source_Node_ID, value=0 from node 13 alarm_report

3/6/2018 8:28:36 AM: parameter ZWave_Alarm_Type, value=6 from node 13 alarm_report

3/6/2018 8:28:36 AM: zwave_alarm_type set with value of 6 from value 6

3/6/2018 8:28:36 AM: parameter ZWave_Alarm_Event, value=23 from node 13 alarm_report

3/6/2018 8:28:36 AM: Unprocessed parameter Number_of_Event_Parameters, value=0 from node 13 alarm_report

3/6/2018 8:28:36 AM: RM: Garage is empty


3/6/2018 8:29:15 AM: SceneTrigger [Auto] Alarm - Garage Door Main: Device Garage Door Main changed to 255. Running script activateScene.cs.



rscott posted this 3 weeks ago

Is that node 13 set to audit? It seems like it's missing the actual value where it triggered the change to value 255 (the values at 8:28:36 AM appear to be turning it off/closed instead of on/open).

MadSci posted this 3 weeks ago

It was not, here is what it looks like with auditing on, this time the motion sensor (node 2). The sensor was triggered very close to the start of the file and finally two scene executions due to the sensor finally at the end (Alarm - intruder motion (which fails due to conditional statement) and Lights Office On. Also, Node 29 is the other motion sensor (same brand) in another room. 

On the app and on the desktop, the devices clearly toggle correctly and on time. It appears that the variable change is held up in a buffer for some reason, until some time later it executes and propagates through the scenes. If I trip the sensor multiple times before the light turns on the first time and then leave the room, once the light turns on, if I turn off the lights remotely right away, they will come back on after a minute or so without the motion sensor being triggered due to the history of the device eing triggered.


MadSci posted this 3 weeks ago

Sorry, I realized that I actually didn't turn on auditing for the motion sensor. Here is the garage door (node 13) from this morning. The log starts with the notification when the garage door is actually opened (and shows up as such on Axial) and then eventually scene is triggered about a minute or so later: