IP camera screen crashing Android app

  • 434 Views
  • Last Post 13 March 2018
f0ggy987 posted this 13 October 2017

I got my IP camera working on the desktop app, both live video and still images.

I punched a hole in my firewall so I could see the camera from the Axial Android app on my phone.

In the app. I can grab the tiny thumbnail still images on the IP camera screen, but if I touch the camera it crashes the app. Should I not be able to open another screen to see the live stream or at least bigger version of the still image?

This is the only time I've seen the app. crash and it is repeatable 100% of the time.

Latest version of the app downloaded from Google Play running on a Galaxy S6 Edge.

Thanks

Attached Files

Order By: Standard | Newest | Votes
rscott posted this 18 October 2017

Which edition of the app are you using (free/paid?)

f0ggy987 posted this 18 October 2017

"Axial Control Paid" I did check in the Play Store, it does not list any pending updates to the app.

zharvek posted this 13 November 2017

Hello, I also have the same problem. I am using the free edition android app with the pro version of Axial Control.

I do not get any thumbnails at all, and clicking a camera crashes the app. Android 7.0 on Samsung Galaxy S8.

I am able to see the still images on the server side, and in a browser. My images are hosted on a public http server, no auth. I modified the source to the C# Ip camera plugin to allow the same URL for all cameras (using BlueIris), just different file names. Working great on the server side, but remote has the issue.

Crash was happening with the non-modified plugin as well, nothing relating to the single line code change.

f0ggy987 posted this 06 December 2017

Any update on this?

Let me know if you need more information/testing.

jalexander319 posted this 19 January 2018

I have 2 Foscam cameras, an 8918W and a 9804W. The first I coudl setup using just the IP and the second I had to add the snapshot and video urls. Both are working in the Avial server app. I just figured out how to view them as devices in the mobile app and I was pleasantly surprised to see them both listed and to see tiny little snapshots appear saying "snapshot from just now".

But, as foggy states, when I click on either camera, the app crashes a second or two later.

I have not done anything in terms of port forwarding or anything on my router in case that could have anything to do with it.

What ~should~ happen when we click the cameras in the mobile app?

jalexander319 posted this 22 January 2018

bump

f0ggy987 posted this 23 January 2018

I just discovered that on my ancient Motorlola Xoom tablet (running Android version 4.1.2) IP cameras work - I get the live video feed in full screen.

Not sure if that helps with troubleshooting the issue on newer phones.

As already mentioned I'm happy to provide more test results, etc. if needed.

zharvek posted this 06 February 2018

Late to this, but I have found that if I visit the list of cameras and the images do not show up, I background the application, and open it again (or bring it back into forground) and then the images will show. 

It's almost as if you need to be on the cameras view while it's connecting to server and "connected to server" notifications popup.

rscott posted this 24 February 2018

@all

For those of you using the paid version of the app, you'll see a new beta show up in the next few hours. Please reply back here if your crash has been resolved. Thanks!

Here's how to opt into the beta.

f0ggy987 posted this 13 March 2018

Hi Ryan,

 

Apologies for the delay - This appears to have fixed it, thanks for your work! I'm getting the camera control screen (instead of a crash), but I cannot confirm 100% that the feed shows because I had to re-IP my camera - is there anyway to update the IP address in Axial? I don't see any option for this. It looks like I would have to delete the existing camera and a new camera with the new IP, is that correct?

Thanks

Close