Leviton DZs15-1L Polling disables

  • 661 Views
  • Last Post 20 May 2017
pir8radio posted this 18 April 2017

I know I have asked this before, and I got a response, but I couldnt find that post, maybe it was an email.    I have a few Leviton DZS15-1L wall switches, as well as some leviton dimmers that "fall out of poll" meaning i set the poll check box and set 30 or 60 seconds, works great for a day or so... then just stops...  I go into the switch in axial and my check box for polling was disabled.   This switch doesnt support assoiciation (as far as i know) at least i can't set it in any of them using axial.   Any idea why these keep poping out of polling?

Order By: Standard | Newest | Votes
rscott posted this 18 April 2017

There's an option that automatically disables a device if it Axial detects it is causing a network slowdown. This may be what's going on - if so, you should see that in the logfile. If you don't care, double click the device and make sure that it's not set to disable polls on device failure.

pir8radio posted this 18 April 2017

already looked at that setting it is not checked.  Thats where I am a bit confused as to how it keeps disabling.

 

EDIT: well the only setting i see is "Mark this device offline when polls fail" and that is not checked..  Am I missing something?

pir8radio posted this 18 April 2017

any other ideas?  Not sure why Axial is removing polling on its own...  Is there a different/hidden setting to disable this?

pir8radio posted this 06 May 2017

So, this breaks a few of my scenes, any way to stop this?      One of my switches will "uncheck" polling almost instantly.. I check the box close the device reopen the device and its already unchecked... do it again, it stays checked for a few seconds, close reopen and its unchecked again..   Yet a force poll works instantly... so Im confused.  This seems to be the last bug I have with Axial..

rscott posted this 09 May 2017

Can you look at your logfile to see if it says the device polling was disabled?

pir8radio posted this 09 May 2017

What log file?    The /axialControl.com/AxialServer/Logs log files only show startup of the application.  Err log is empty. is there a different log i should be looking at?

rscott posted this 10 May 2017

logfile.txt - it's in the main folder. You can find it by going to the help & support menu.

pir8radio posted this 10 May 2017

 Here is what was in the log, yet every manual poll works. This is hppening on about 7 of my switches all the same model.

5/10/2017 6:46:26 AM: Polling disabled for nodeId 31 because of too many APPLICATION_BUSY reports. Try rebooting device.

5/10/2017 6:46:33 AM: Properties requested for device d07d4015-07ff-4998-96fb-524a973b38f4

5/10/2017 6:46:33 AM: Found device: yes

5/10/2017 6:46:33 AM: getDeviceDetails: 1

5/10/2017 6:46:33 AM: getDeviceDetails: 2

5/10/2017 6:46:33 AM: getDeviceDetails: 3

5/10/2017 6:46:33 AM: getDeviceDetails json: {"lastCommunication":"2017-05-01T10:41:58.7165059-05:00","queuedCommandCount":0,"pollTimeSeconds":60,"isSleeping":false,"pollDevice":false,"smartRoutePolling":true,"enableReporting":false,"mobileHidden":false,"shortId":91,"auditNode":false,"pushUpdates":false,"allowRoomManagerUse":true,"queueCommandsUntilWake":false,"neverUseSecureComms":false,"markOfflineNoComms":false}

 

rscott posted this 10 May 2017

That's a quirk with Leviton switches - every now and then they'll get in a bad spot and throw this error on poll attempts.

Do you have an airgap switch on yours? If so, pull it out to force the switch itself to power down and reboot. If you don't, you may try cutting power to it from your break/fuse box and see if that helps clear out the application busy error. 

pir8radio posted this 10 May 2017

I wish it was just every now and then.     If i pull the aeon usb stick and plug it back in it starts working again for a day or so.  Same if I reboot the actual switch.   I did not have this issue when paired with the vera plus system...  And when i force poll the switch it works. Is there a hidden setting that can stop axial from disableing the polling on its own?    When I enable it the switch status updates then it disables polling... 

pir8radio posted this 11 May 2017

update, i just pulled the airgap switch, let it sit for a min, and re-enabled...   Tried to turn polling on via axial, closed properties, re opened it and it was disabled again.  I right click and "force poll" and the status came in instantly..      

pir8radio posted this 16 May 2017

So,  again a force poll will always return the status...    why doesnt the normal poll?    and why does it disable if the force poll works?  Can a feature be added to NOT DISABLE POLLING?      Or maybe for these devices force poll every 60 seconds?   OR, only diable if missed 5 polls in a row, back to back?    something...   its killing me.. lol    my scenes no workie...

rscott posted this 17 May 2017

I can make you a build that that that uses that same checkbox to ignore the application_busy response. It was added originally because the Aeon Labs S2 stick would lockup after recieving too many of those. Hopefully that's not the USB stick you use :)

Here's version 4.1.6346 - let me know how it goes for you.

pir8radio posted this 17 May 2017

Sweet!    I use the aeon labs Gen5 stick, ill try...   

pir8radio posted this 17 May 2017

 I get access denied when i click that link.

rscott posted this 17 May 2017

Sorry about that, try now.

pir8radio posted this 18 May 2017

Thanks!  Installed and scenes working!  I'll report back if things act up...  Thank you so much!   I was starting to look at different switches, and I don't really want to re-buy them all...

pir8radio posted this 20 May 2017

so over the last 2 days, this version has been working perfectly... I've been struggling with these switches for a while now. Is there an option you can add to disable this? I dont want to have to bug you for a special version every time i upgrade to the latest version. :-)

rscott posted this 20 May 2017

It will automatically be included in the next official release that goes out, so you won't need to worry about pestering me for a special change. :)

Close