Win 10 Build 1607

  • Last Post 19 October 2016 posted this 03 October 2016

I'm having a problem with the drivers for HUBZ.  They quit working (and cannot be installed) with win 10 build 1607.  Anyone else have this problem?

Order By: Standard | Newest | Votes
rscott posted this 03 October 2016

What happens when you try to install them? posted this 03 October 2016

Just a fail notice at the end of the installation process.  The devices are in the Device Manager as having no driver (code 28).  I rolled back the update and they work now but freezing updates is not really a solution.

rscott posted this 05 October 2016

I contacted the manufacturer and they mentioned that Windows 10 now includes a native driver for that device. They didn't include any specific instructions as to how to use it, other than the fact that they just plugged in and go. I'll try some testing here too... can you confirm which stick it is? Is it number one or number two? posted this 05 October 2016

I have both.  The one I am using is the z-wave-zigbee stick.  I have not tried the other.  I will try it out later today.  It's too bad the stick is a single point failure for the system.  It would be nice to be able to copy the control to another stick rather than have to rebuild the system.  That way you could keep a backup.  I intend to integrate my home security with the automation this time. posted this 11 October 2016

Checked my devices again.  I have two of the HUSBZD-1 devices.  With the new build they both could not find drivers and attempting to use the existing one failed.  If Nortek has a driver for Win 10 could we get it?  It is not in the configuration of windows I have.

rscott posted this 11 October 2016

I talked to Nortek again. They are looking into this a bit deeper because it seems the USB stick does not actually work with native windows drivers as they originally reported.

I would also recommend talking to Nortek Support, as having a customer knock on their door may help net results quicker. If you do, please keep me updated on what you learn.

rscott posted this 11 October 2016


Could you try the install again after disabling the unsigned driver enforcement?

Simple way (in some cases it might not work or require some additional steps in Windows 8/8.1/10):

  1. Restart PC
  2. Press F8 repeatedly just after UEFI/BIOS intialization and just before Windows would load
  3. Select “Disable driver signature enforcement” option.
  4. Install drivers. After you restart your system again you won’t be able to install unsigned drivers until you repeat the steps 1-3. posted this 12 October 2016

I was sure the unsigned driver control was turned off.  Disableing that did the trick.  In reading about it I see that there are two ways to do it.  One is permanent and one is for that restart.  I've had updates before and the driver was never bothered so I assumed it was still in effect.  I really wish they would let me set things and leave it that way.

nelis249 posted this 19 October 2016

Driver signing has been there since Win7 x64 bit. I do driver development have been through the channels to get drivers to install properly. In device manager does it show as a Microsoft driver? It might be that Nortek submitted the driver for the Microsoft approval process but in doing so the signing portion is incomplete. Believe it or not, driver signing is important part of security. I do not recomment disabling it perminenantly. posted this 19 October 2016

From what I have read, there are two ways to get an unsigned driver in.  One is to use Test Mode, the other Settings.  I have not tried Test Mode because that is the one that turns it off for everything.  It is supposed to put up a watermark to let you know that as well.  The other method is to use Settings.  That disables the driver signing for that restart only.  Once the driver is set, subsequent restarts are with the signature enforcement enabled.  This allows you to do a one time override.  

The driver is identified as Nortek's but is digitally unsigned.