Philips Hue

  • 33 Views
  • Last Post 01 July 2020
nelis249 posted this 11 June 2020

 Anyone else having an issue that Axial isn't connecting to Philips Hue? It literally worked fine last night and tonight no go. I noticed the bridge had a firmware update released yesterday.

Release notes here: https://www2.meethue.com/en-us/support/release-notes/bridge

It says they changed the discovery message so I'm wondering if the Axial plugin needs an update to 'discover' the bridge correctly. Also when opening the GUI and going to the Hue Controller it responds with a 404 and the pull down is blank.

The Axial logs have this:

6/10/2020 9:29:08 PM: HueUI: getHueUser() thDlHOyNQOcns0zBGxgcS7KDsAyUJo6XyznX6I8x

6/10/2020 9:29:09 PM: The remote server returned an error: (404) Not Found.

That ID is valid as it works if I manually goto the URL: https://x.x.x.x/api/thDlHOyNQOcns0zBGxgcS7KDsAyUJo6XyznX6I8x/lights

I can see the JSON response and has all the light data in it.

I opened a support ticket on the Axial site. Was just curious if anyone else has has this problem.

nelis249 posted this 01 July 2020

Alright, I had some time to do a little bit of reverse engineering. Using wireshark I found out that Axial is calling out to a web url http://www.meethue.com/api/nupnp. Looking up that address yields a 404. This coincides with the 404 that I see on the Hue Controller. 

I searched around for meethue information and found that they some how are publishing the bridge in their cloud. I stumbled on a developers page that pointed to this URL https://discovery.meethue.com/. Going to that, resolves and it displays, in JSON format, my bridge IP and an id. I find it interesting concept that the Hue people are purely using my resolved IP address to get this information. I would have thought SSDP would have been eaiser and not cloud dependent (yikes petnet!).

Anyway, what I did then is configured my main firewall to do a URL redirect from meethue.com to discovery.meethue.com. After a few minutes of tinkering with the configuration I was able to get it to redirect (first tested on a browser). My Hue controller now seems to work properly.

End Game: The Axial Hue plugin needs an update.

Close