Adding weather conditions to scene conditions

  • 339 Views
  • Last Post 20 August 2017
jonnysax posted this 10 August 2017

I currently have an automated garden watering system in place that I could with turn on manually or I could set up a daily trigger. However, what I wish I could do would be set up a daily watering based on the weather conditions. For example, if today I got no rain, the system would kick on, but tomorrow if it rains more than .25" it would not kick on automatically. How hard would it be to set up a weather feed as a condition in the scenes? I'm sure others would love to set other devices such as lights to change automation based on weather.

Order By: Standard | Newest | Votes
rscott posted this 10 August 2017

You could use the weather device plugin, then break out the reading you are interested in to its own device (see first screen shot in this tutorial), such as "rain fall" - then use that device as a condition in the scene that turns on the watering system.

jonnysax posted this 10 August 2017

 Perfect!  exactly what I wanted.  Thats why i ask... because this software has so many unknown (to me) options, sometimes its hard to figure out how to get it to do what I want.  What are some other use cases for these break outs?  

jonnysax posted this 12 August 2017

hmmm... is there a trick to keeping this weather updated?  its still says the same numbers on all the parameters as it did the other day.  its been raining the last few hours and the rain still says 0

rscott posted this 14 August 2017

Does your weather show as updated on the Open Weather website where you setup your personal API key? Is there anything in your logfile.txt that would suggest a problem with downloading your weather?

jonnysax posted this 14 August 2017

most things on here are updating, temp, cloud cover, weather condition code, etc... but all the rain related stuff is not updating.  For example, my F24hrain said 1.76mm when i first added the plugin(it was going to rain that night) but it still says 1.76 and always showed 0 on the last3hrain parameter, even during and after the rain. 

I'll have to look at my log file, but if the other stuff is updating, its not a problem with the connection.  

rscott posted this 19 August 2017

I'm just wondering if Open Weather itself is not updating your information?

jonnysax posted this 20 August 2017

ok, it seems its updating most parameters but not all.  seems kinda hit or miss... when i cick on the weather level displayer on the right hand side here is what it says:

Last3hRain - 0mm  (this has never changed to anything but 0)

F3Hrain - 0mm  (this has also never changed to anything but 0)

PrecipIn24H -  (this has changed to other than 0 but its not accurate and for several days straight through rainy and sunny weather it read 1.76mm)

All other parameters seem to accurate... Cloud %, wind speed, visibility, temp...  just the one i need is all weird... figures.  ha ha

Close