Aeon Labs ZStick S2 Firmware updated to 3.08, now some devices don't work....

  • Last Post 04 July 2016
  • Topic Is Solved
LeapFrog posted this 02 July 2016

My Aeon Labs Series 2 USB ZStick has been slow to respond ever since I bought in two years ago.  In a quest to speed it up and increase reliability I updated the FW today to 3.08 (

Now some (but not all) of my devices don't respond to some requests, although they respond to others.  See log attached where one device (Node 2) responds to power on/off requests, and the second one (Node 5) does not.  Both nodes respond to getDeviceDetails.

Should I try a downgrade to 3.07?  Any suggestions are welcome.  

P.S. Ryan - Why can't we attach a .txt file here (nor a zip file, nor a .docx)? - Seems like those would be logical file types to least, please put some instructions about what types are allowed so we don't have to spend our time guessing which ones are alllowed.  Thanks.


Attached Files

Order By: Standard | Newest | Votes
cowinger posted this 04 July 2016

I too have the gen5 z-stick. I have had it for almost 3 months now. I have had no problems at all having it include z-wave plus and regular z-wave devices. Doing auto-configuring and associations worked flawlessly. The device status time usually is around 2-3 seconds. Battery levels and for example multisensor readings all come in just fine. I was able to include all of my devices from where they were installed without any problem. It is a great controller.

LeapFrog posted this 04 July 2016

Glad to hear I can expect better reliability from the G5 controller.  The S2 does seem to flake out from time to time, especially when polling devices for changes in state.  I've been able to work around that for the most part by configuring the device parameters to either use 'hail' (to force a poll) or 'basic report' to update the device status with the associated Series 2 controller.  But even then, sometimes it can take 15 seconds or more for the controller to report the updated device status back to InControl.

Will report back when I have some experience with the G5 version.

Update: As reported below by others, the G5 controller works a treat!  No issues with device inclusion/exclusion or command execution.  We'll consider this issue solved.

weidnerj posted this 04 July 2016

I have had 0 problems with Gen 5 controller.  From time to time I would have issues with the previous model. 

LeapFrog posted this 03 July 2016

I see there is a Z-Wave command now in Tools that says "Transfer Network to New Controller".  I can't find anything about this in the online Help file, user documentation, or release notes.  And the link to an Axial Server  discussion about this ( points to a post in the old incontrolha forum whose link is broken.


Has anyone tried this and does it work?  (And Ryan, how about fixing the broken link)?

LeapFrog posted this 03 July 2016

Update: I rolled back to 3.07 and everything seems to be working OK at the moment.

I am going to order a Gen5 stick and we'll see if it performs faster and more reliably than the Series 2.