Struggling with Aeon Lab Device Config & Lag - Topology?

  • 96 Views
  • Last Post 02 August 2018
ad.wightwick@gmail.com posted this 20 July 2018

Hi,

 

I'm trially the Pro Edition of Axial Server to try and setup a Z-Wave network to control some lights in a fairly basic fashion.  I have a meeting room with 3 banks of LED lights, 4 lights in each row so a total of 12.  I have a control PC (Win10 x64) with AxialServer 4.1.6325.20458 (Latest Stable) installed.

 

The PC has an Aeotec Z-Stick Gen5 (ZW090), all the lights are connected to Aeotec Smart Switch 6 (ZW096) and I have x3 Aeotec Quad Wallmote's (ZW130).

 

I have sucessfuly paired all the devices to the Z-Stick, identified them all and renamed them in Axial.  I then setup 30 second polling on each device and enabled Smart Route Polls.

 

My aim:  Is to initially configure one Wallmote and then mirror the config to the other 2 Wallmotes (we need 3 Wallmotes all acting the same as the room is a huge meeting room with multiple entrances/exits):

Button 1 - All lights on

Button 2 - All lights off

Button 3 - Lights B2,B4,C2,C3 only.

Button 4 - Lights C1 & C4 only.

 

My issues so far:

  • I've managed to set the scenes up in AxialServer no worries.
  • The first Wallmote I have setup has a massive lag time between touching Button 1 and all the lights coming on.  For instance I have just touched button 3 and it has taken 2 minutes for the lights to turn on and it takes the same amount of time for them to turn off.
  • Sometimes when a button is pressed there is lag between the switches as well.  For example If I press button 1 to turn all 12 switches on I might get 5 turn on after about 30 seconds but then a minute later the rest slowly turn on over maybe 15 seconds - just really strange.
  • I have selected 'Mirrors' on Wallmote 1 and selected Wallmote 2 & 3 however it does not appear to be mirroring the config to these devices.
  • My topology looks very wrong, I have moved icons around to visually represent our meeting room.  There is a lot of red, I feel this may be why there is so much lag.  (I have attached an image of my Topology - Screenshot-IMGUR)
  • I've tried to 'Heal' the network but this has not fixed anything.
  • The group associations is really confusing, I'm really unsure as to how these should be selected/setup to help me do what I am aiming.  I know Group 2,4,6 & 8 corellate to Buttons 1,2,3,4 but does group association affect the Topology and therefore lag?  Ideally I want the Wallmotes to communicate directly to the switches, I thought that was the whole point of the Z-wave to make a mesh network and route the commands through other devices quickly.  I also understand group 1 associate is the 'Lifeline' (whatever that means) but for all my devices it has the Z-Stick already preselected in group 1 so I have not touched it and left it as is.

Any guidance would be greatly appreciated.

 

Thanks in advance

Attached Files

Order By: Standard | Newest | Votes
jonnysax posted this 20 July 2018

I've never worked with the wallmotes, but i do think i see whats causing the lag... try turning off the 30 sec polling, those wallmotes are on battery power and only send a change of state signal out if they are touched, polling them wont do anything but bog down your system.  

Also instead of using mirrors, why not just make button 1 on all three wallmotes the trigger forthe "all lights on" scene and so on...  

hope that helps!

jonnysax posted this 20 July 2018

Should look something like this:  

"All lights on" scene

Devices:  A1 through C4 "on"

Triggers: Button 1 from Q1, Button 1 from Q2, Button 1 from Q3

Conditions:  none

ad.wightwick@gmail.com posted this 20 July 2018

@jonnysax thanks for the reply.  I'll try those suggestions in the morning, do I turn the polling off to the power switches as well?

 

-Any idea whats with all the red lines on the Topology map?

-In the Group Associations which devices should I have selected for 1,2,4,6 & 8?  Do I associate all the devices with each other?

rscott posted this 20 July 2018

I agree with Jonnysax, I wouldn't use the mirror feature in this scenario, but would instead program each button on each remote specifically using the groups as you've done with your first wall mote. The advantage of doing it this way is that the command is going directly from your wallmote to the lights. 

Using groups 2,4,6,8 to turn the lights on/off directly is the correct way to configure it for direct communication. You asked if it impacts topology... I'd have to say no, but I'll clarify that it will be impacted by that topology -- in that if the switch cannot communicate directly with the light, it will need to relay the command to other lights (hence the mesh). The mesh can become slow if it is being bogged down by commands, so you may consider changing polling to a higher frequency or disabling it all together just to see if that helps.

Certainly as Johnnysax suggests, you do not want to poll your battery powered wallmotes.

To heal, you'll need to make sure your wallmotes are awake, since they are battery powered, they'll ignore the heal command by default. The manual has some information on how to wake them up. I would suggest using the topology screen, then waking up each switch one at a time and performing a right click on each to discover/heal that node.

Can you give us an idea of the size of the room?

rscott posted this 20 July 2018

-Any idea whats with all the red lines on the Topology map?

 

The red lines mean that the device cannot communicate directly with the other device.

 

-In the Group Associations which devices should I have selected for 1,2,4,6 & 8?  Do I associate all the devices with each other?

 

The associations are for the wallmotes themselves. You'll click the associations button for the wallmote, then load group 2; any light you have checked in group two will turn on/off by tapping button 1 on the wallmote. You do not need to do any associations on the light devices themselves, other than perhaps leaving group 1 set to the USB stick.

 

ad.wightwick@gmail.com posted this 20 July 2018

@rscott We are in a testing/config phase prior to site implementation so we can get it all setup and then drop the preconfigured setup into the active workplace quickly, the room currently being tested in is very small, a lab office space only 11.5ft x 8.2ft.

 

The actual room we are going to implement in is approx 53ft x 33 ft - it also has a sloping 45 degree vaulted ceiling with an averaged approx height of 18ft.

ad.wightwick@gmail.com posted this 20 July 2018

The red lines mean that the device cannot communicate directly with the other device.

 

So I guess then my next question is what is the most optimal way to set this up so we have the clearest form of communication between devices (ie all green)?  As you can see from my Topology map Q1 (Quad Wallmote 1) only had a green link to C2 and red out everywhere else?

 

Is this something that can be controlled?  Is that through healing?  When I tried to heal the network I had put the wallmotes into Wake mode and the Heal said it was ok and didn't show any errors.

rscott posted this 20 July 2018

Ok, if you are currently in a room that small, I wouldn't expect your topology to have any red lines, unless there are some large metal structure or other types of items that would seriously disrupt radio signals. 

You might try to exclude each of your wallmotes then re-include them again at the actual location where they'll be used and see if that helps. Note that the easiest way to do the inclusion might be to use the "network wide" version.

ad.wightwick@gmail.com posted this 20 July 2018

Yeah, in the test room I have a laptop, x2 desktops a printer and a Netgear R7000 Router in the room but no other obstacles or structures.  All the equipment is laid out next to each other on a couple of powerboards on an open tabletop.

 

I have tried excluding them as you suggested and even resetting the Z-stick.  I followed the guide from your website when I tried adding the devices originally.  The first time I tried it out I would set AxialServer 'offline' then used 'Add Device (Network Wide)' and did this with each device.  When that didn't work thats when I tried excluding and resetting the stick and then I tried adding them to the Stick with Near-Field comms, if you push the button on the Z-stick and put it into Include mode, hold it near the Z device and push the Z button you can pair quickly.  Unfortunately still got the same result.

 

 

So the red lines on the topology has nothing to do with the group associations then, it is representing the way the devices have set the mesh up themselves?

rscott posted this 20 July 2018

That's correct, the red lines won't be impacted by the group associations. 

What happens if you go offline inside Axial... do you still get the lag? If not, then it could be overpolling that is causing the lag. 

ad.wightwick@gmail.com posted this 21 July 2018

So I turned secure comms off to all devices and turned polling off to all devices.  This has helped significantly and healing the node via Topology fixed the red links.

However, when I try to set the Group Associations on the wallmote, it is not remembering my settings correctly.  For example I go into Q1 and set Group 2 to associate to the 12 smart switches.  I exit the Associations and go back in but only the top 5 are still checked/selected?

Got the scenes all setup, however when I looked under triggers the option to select a specific button on a set remote was not there.  The only 4 options are 'at a specific level' - 'turning on' - 'turning off' - 'changing to any level' ?

rscott posted this 21 July 2018

According to the documentation, each group can only be associated with up to 5 nodes, which is why you only see the top 5 "sticking" when you set them.

Those wall motes might be compatible with the "Scene activation button" feature. To check, right click on the Q1 device and choose that option. Here's a video that goes into a bit more detail on how to use it: 

The idea would be to ignore the group associations all together and use Axial Server to control the lights when a given button is pressed.

ad.wightwick@gmail.com posted this 22 July 2018

Fantastic, thanks for the video!

Got it all working with one caveat, unless I have AxialServer software open on the PC and 'HA Server' slider is set to the online position that is the only way it works.  Does that sound right?

If I slide the slider to 'Offline' it stops working instantly.

jonnysax posted this 23 July 2018

yep thats how it works.  the slide gives you the ability to refresh the service without shutting down.  say you make several changes in a scene, then you slide to offline and back on, and the scene will be immediately available.  For this to work well, it need to be on a PC that stays on all the time.  

rscott posted this 23 July 2018

If you could get away with using group associations, you wouldn't need to use Axial. However, since your wall motes can only control up to 5 lights per group, it appears to not be an option for you. 

The other option is to not use group associations but instead allow Axial full control, which is what that "Scene activation button" does. In this mode, the wall mote is sending a command to Axial, which then activates the given scene you selected.

ad.wightwick@gmail.com posted this 26 July 2018

Thanks very much for both of your assisting with my troubleshooting, its been very helpful.


 

My last question, how can I set a switch state on loss of power.

Currently if the power to the switch fails it returns to the state it was set in.  I'll give you an example:


 

My quadmote has 5 emergency lights set on group association (nodes 6,7,8,9,10) and AxialServer is handling all the scenes from the PC/Z-stick (which is in a locked IT rack at the facility).  The users know that if they use a quadmote and those specific lights in that room turn on only in this pattern, that there is an issue with the automation system and they can contact IT support to get it resolved either remotely or on-site.  So lets say the power to the meeting room fails, Axial PC shutsdown.  When the power comes back on we may not be able to get someone on site straight away to boot the PC back up to restore AxialServer's link to the quadmotes.

What would currently happen is the lights that are on when the power fails will resume to the original state when power is restored, however the quadmote will only allow the 5 group association lights to turn on/off via the associated button #1.  That is fine however, lets say the meeting room was in the 'ALL ON' scene when the power goes out (so all nodes 2-13 have power on).  What happens when the power is restored they will all turn back on - the issue is when someone tries to use the quadmote button 1 to switch them off, nodes 6,7,8,9,10 will turn on/off however nodes 2,3,4,5,11,12,13 will be unaffected and will stay switched on.

Even if I have no group associations set and I'm just letting Axial manage scene commands on its own, there is obviously no control at all and all the lights would come back on and I have a similar predicament.  At least with the group association users will still get some limited control.

There should be a way to tell the switches to turn off rather than returning to their original state on power loss, I know I saw the option when I was testing OpenHAB, does Axial have this option?

rscott posted this 26 July 2018

I think setting the default state would be a configuration option provided by the manufacturer. If you can determine if Aeon labs has that option, then you can use Axial to configure it.

Also, to handle the specific scenario you describe, you would want to make sure you PC powers back on when power is restored (this is usually a bios option), then in Axial's tools/options, make sure the option to "run as a service" is selected. That way, when power is restored and the PC is rebooted, Axial will start up automatically and be available to run the scenes without any intervention from the IT staff.

nelis249 posted this 02 August 2018

My 2cents... Never run a PC without an UPS. Get a 1500 or higher. It'll run a single mid tier PC for an hour or more.

https://www.amazon.com/CyberPower-CP1500AVRLCD-Intelligent-Outlets-Mini-Tower/dp/B000FBK3QK/

 

Close