Unprocessed Command

  • Last Post 26 August 2019
  • Topic Is Solved
n0vtn posted this 12 August 2019

My system has become rather sporadic lately. At times it seems more responsive than ever. But at other times it's impossibly slow. I have tried healing the network, restarting my PC, Powering off my PC for a while, and now I am looking at the log file. I am seeing thousands of these events.

8/12/2019 5:03:12 PM: MC: Unprocessed command: 50, 2, 33

8/12/2019 5:03:12 PM: MC: Unprocessed command: 50, 2, 33

8/12/2019 5:03:12 PM: MC: Unprocessed command: 50, 2, 33

8/12/2019 5:03:12 PM: MC: Unprocessed command: 50, 2, 33

8/12/2019 5:03:12 PM: MC: Unprocessed command: 50, 2, 33

8/12/2019 5:03:12 PM: MC: Unprocessed command: 50, 2, 33

8/12/2019 5:03:12 PM: MC: Unprocessed command: 50, 2, 33

8/12/2019 5:03:12 PM: MC: Unprocessed command: 50, 2, 33

I have tried searching this forum but I am not finding anything on "Unprocessed Command"

Are these device numbers? or something else?

Every 30 seconds or so I get about 50 of these, many occuring within the same second.

Thanks in Advance.


Order By: Standard | Newest | Votes
rscott posted this 13 August 2019

That suggests it's a multi-channel device of some sort. Do you have anything that might support multiple devices in one -- for example, the Aeon Labs Smart Strip is one such device.

Other things that could cause a slow down:

- Spammy devices, such as those that report temperature, humidity, light levels can cause lag if they are set to report too frequently

- Polling battery powered devices (turn off polling for battery powered devices)

- Polling devices that are themselves slow to respond (increase the poll time to a higher value)

n0vtn posted this 14 August 2019

Yes, I have two of the Aeon Labs Smart Strips and a Zooz smart power strip too.

I have several of the multi sensor type devices, five of the early model Aeon Labs multi Sensors, one newish Aeon Labs Trisensor, plus a couple of Zooz sensors. I was hoping the log might point me toward which device is giving me the trouble. There are about 60 physical Z-Wave devices at this location.

Every weekend when I go there I find one or more devices not working. Sometimes a power cycle, or a network heal is all that is required to get them responding again. Sometimes removal and reinclusion is required. Sometimes I need to replace the device. 

rscott posted this 15 August 2019

You might start with the smart strips. A quick google revealed this PDF which mentions around section 3.3 that you can change the report time. You may play with the settings on your own to adjust how often it reports back changes to Axial. This may reduce the "MC" log too (though it may be unreleated to the slowdowns)

n0vtn posted this 19 August 2019

I've been palying with the update settings on my smart strips. so far no change. The defauld update interval is 600 seconds, or 10 minutes. My log file goes nuts every 30 seconds or so.

My log file is generating 62000 lines of data every 24 hours. Nearly all of that is the Unprocessed Command shown above. By my estimation I am well in excess of 50k unprocessed commands every day. That seems like a lot. Even if I treat those trailing numbers as hexadecimal, and convert them to decimal they don't match up to any of my smart strips or my sensors. 

I am thinking that error is generated on my Z-Stick rather than from InControl/Axial. It looks to me like Axial Control is trying to make something happen (some sort of broadcast, maybe?) in 30 second bursts and it is getting these errors back from the Z-stick as it fails to process the command. 

For what it's worth, I don't see any Unprocessed Commands in the log on my home system, only on the one up north. The one at home has far fewer devices and would be a lot easier to troubleshoot by elimination. Guessing and trial and error is a tough way to troubleshoot a system this size and also so far away. Hopefully it will turn out to be an unresponsive device that I discover when it doesn't work.

n0vtn posted this 26 August 2019

I just returned from our cabin where the issue was.

It was the Zooz Power Strip which was causing all the Unprocessed Commands.

This device reports a lot of parameters, power consumption in W and Kw/h both per switched port and device total. It also reports battery life (Why? it doesn't have a battery). It also reports a number of other parameters which aren't identified. It was doing this every 30 seconds.

I don't need any of these parameters, just individual outlet control. I don't care how much my Internet router is consuming, I just need it on. 

Anyway I was able to turn some of this off completely and set the rest to report once per hour, vs twice per minute.

Thanks for the assistance!