Can't operate bulb with switch

  • Last Post 06 June 2018 posted this 03 June 2018

I have Axial Server 4.1.6325.20458 Standard Edition, and am trying to set up:

(1) AotecZ-Stick USB Controller

(1) GoControl LB60Z-1 light bulb

(2) GoControl WA00Z-1 battery powered switches

(1) Eaton RF7595 battery powered switch

I think I have included all the devices in the Z-Wave network, as they all show in the devices panel in the Axial Server GUI. The light bulb shows up as a "Dimmer Switch" and I can turn the bulb off and on using the power button on the device in the Axial GUI.

I have associated all three switches with the Light Bulb/Dimmer Switch (which show in the GUI as (2) "Wall Controllers" (GoControl Switches) and (1) "Controller" (Eaton Switch)). But I cannot turn the bulb on/off with any of the three switches.

I'm generally tech-savvy but I'm new to Z-Wave. What do I do to diagnose and/or fix the problem?

Thx, Gus





Order By: Standard | Newest | Votes
rscott posted this 03 June 2018

I'm not clear on how your associations are setup, so I'll just out line how they should be and you can confirm/verify on your end:

  • Click the switch you want to use to control the bulb
  • Click "associations" 
  • The window should open up and show a list of devices
  • Find the bulb and make sure it is selected
  • Find the USB stick and make sure it is selected
  • Switch to group 2 by typing 2 into the group box then clicking the load button
  • Again, find the bulb and make sure it is selected (not usb stick for group 2)

If your bulb supports associations, its own associations should remain unset. 

Also verify that your switches are only associated with the Bulb and/or usb stick, and not other switches.

NOTE: I'm not sure how the Eaton device works, but you may not be able to load associations for group 2. That's probably OK if that ends up being the case, group 1 is generally the important one. posted this 03 June 2018

Thanks to the above, I got the Eaton switch to work, still can't get either of th gocontrol devices to work. I've tried resetting the gocontrol switched, and I can do that, but the 5-green confirmation seems flaky and I'm wondering if the problem is batteries. I have tried replacing the two coin batteries, doesn't help. So:

If I can control the bulb with the Eaton, is it even possible to control the bulb also with a second switch - what electricians call a 3-way circuit?

rscott posted this 03 June 2018

Both can control it. At what point is the GoControl failing to work? Are you able to apply the association to both groups? You might also try to re-load and verify that the bulb remains checked. posted this 04 June 2018

After many attempts, I now have both the Eaton and one Go Control switch operating the lightbulb. Both while I was trying to configure associations, and subsequently after associations for both switches would actually operate the lightbulb, I would frequently get the response "the <device> did not respond to the associated device request" when trying to check status usin Axial server. 

The Eaton switch seems to operate the lightbulb fairly reliably, the GoControl switch less reliably.  The GoControl switch currently shows battery level 61%, and its LED indicator does not always confirm button commands. I note that after configuration using Axial/Aeotec Zstick, the swtches can apparently control the lightbulb whether the Zstick is operating or removed from the PC.

In my ploughing around the net I ran across this on github .....

Based on comments, apparently it's helped some people, but since I'm a newby regards Z-wave I don't know exactly what it is (driver? config file? ...), whether it can be installed or used with Axial Server (how?), etc

At this point my efforts suggest the Zwave wireless equivalent to a traditional wired 3-way electrical circuit is theoretically possible, but not reliable enough to install at a customer site. The only other idea I have is to get a second Eaton switch and see if that works, as the first Eaton switch seems more reliable than the GoControl.


rscott posted this 04 June 2018

It just looks like basic implementation for the device; things that are already implemented within Axial Control.

I suspect that the message about "device not responding" was because it wasn't awake. For battery op devices, they will not respond to commands unless you intentionally wake the device up.

Are you purposely limiting your 3-way exploration to battery powered devices? You can use this powered switch in a 3-way configuration pretty easily. The only requirement is that you give it power, you don't even need it to wire directly to the light it will be controlling. I use that switch throughout my house and it works quite well. posted this 05 June 2018

I'm making progress, and I've subsequently been able to associate both GoControl switches with the bulb, and operate the bulb with them. The switches do seem to be waking up - I'm seeing "WokeUp" messages in the message panel on the right hand side in the Axial Server GUI - but it takes multiple tries to enter and/or display the Associations for the switch. It's possible I'm not using the right button sequence to make/display Associations (??).

At this point, with the GoControl switches, I'm only able to operate the bulbs with the Aeotek USB stick/controller connected and active in the PC running Axial. Is it possible to do "direct association" so that the Aeotek stick is only needed for configuration and not ongoing operation?


rscott posted this 06 June 2018

Hmm, I can't think of a time that you would ever need Axial control open to use associations. If they are setup correctly, they speak directly with the bulb itself and bypass the USB stick and Axial all together. I suspect you have something else going on.

Do you have any scenes that turn on the bulb? If so, could you have mistakenly configured one of them to listen for button presses from the GoControl switch itself? posted this 06 June 2018

I have subsequently been able to get the GoControl switches to operate the light even when Axial/Zstick are not active ... sometimes. Possible reasons for the inconsistency are reliability problems in the switches, button press with no wakeup, low battery (now about 50%) in the switches, slow command response and incorrect button presses (ie. nothing happens and I make another button press).

I'm an electrician, and my motivation is that in some cases electrical upgrades in existing homes could be done much faster using a wireless solution vs. pulling physical wires. I'm new to Z-Wave, learning as I go, and it's frustrating to diagnose issues when behavior is inconsistent (gee, when I take my car to the mechanic it never backfires ....). I don't yet feel comfortable installing this at a customer site, but the potential is there and I'm going to keep testing in my spare time.

I appreciate the help I'm receiving on this forum!



rscott posted this 06 June 2018

I'd avoid the battery operated devices if possible and go with ones where you pull out old switches and replace them with wired ones. They still work wirelessly without the need to pull wires, but because they are always powered, there's one less thing to worry about and you'll get a more consistent experience.